MinMax Spaz

MinMax-Games.com

The water cooler of outer space
  
It is currently Sun 21 Jan, 2018 11:16 am

All times are UTC [ DST ]




Post new topic Reply to topic  [ 54 posts ]  Go to page Previous  1, 2, 3  Next
Author Message
 Post subject: Re: Framerate goes to 1 per second
PostPosted: Wed 30 Nov, 2011 9:24 am 
Offline
Shortbus

Joined: Sun 27 Nov, 2011 4:53 pm
Posts: 8
Richard wrote:
Hmm, are you all up to date patch wise? What is your build number?

What do you mean? It is version 1.011, the latest, downloaded from Steam a few days ago...


Top
 Profile  
 
 Post subject: Re: Framerate goes to 1 per second
PostPosted: Wed 30 Nov, 2011 9:45 am 
Offline
Shortbus

Joined: Sun 27 Nov, 2011 4:53 pm
Posts: 8
Attachment:
processes2.jpg [224.1 KiB]
Not downloaded yet
Blorfy wrote:
Ok it looks like you are on 1.011.

Those setvisible echos are the cloaked afterburners on drones complaining that they don't exist and is totally harmless and gone in 1.012 (not released) The other echos are also harmless and always happen on shutdown. So your log is clean.

The game is detecting you at 3.13 GHz so you have more than enough power to play smoothly. Any hitching should be fairly rare. It is quite rare for me at 2.4 Ghz.

I am almost certain some system process is interfering with the loading of your files. That music doubling is what happens to me when I debug the game (which is VERY slow) and the streamer times out.

In the mean time, if you are heavily drone specialized, I would unfortunately get out of that as they eat CPU more than average and perhaps go cannons for some relief. This may help, but I think there is something scanning each file when it loads.


Ok, that bloody Avast cant be disabled totally, Ill work on that.. under "disabled" options the game still lags like hell, with zombies at least. I tried to monitor the processes running while playing SPAZ (in attachment).. I dont normally play in windowed mode, the lags are just the same anyway. I also changed the affinity to core 1, no change.. Btw I noticed that when being on map with my mothership and 4 ships of mine only, there is absolutely no lag. But thats not so important info I guess. Dont you have any idea what could be the problem? I will try to disable Avast, but.. Im sceptic.


*edit* ok, I disabled Avast totally, and its all the same :-( *sad*

*edit* - and I dont use drones at all....


Top
 Profile  
 
 Post subject: Re: Framerate goes to 1 per second
PostPosted: Wed 30 Nov, 2011 8:05 pm 
Offline
Boomerang
User avatar

Joined: Sun 02 Oct, 2011 12:00 am
Posts: 255
Location: England
Some antivirus apps are notorious for refusing to be properly disabled - not sure Avast is one of those or not but its possible. Could try a complete uninstall of Avast and see if that does anything.

Does your harddrive have ample free space? Tried defragging?

Maybe your video card drivers need updating?

Hope you fix it!


Top
 Profile  
 
 Post subject: Re: Framerate goes to 1 per second
PostPosted: Wed 30 Nov, 2011 10:38 pm 
Offline
Shortbus

Joined: Sun 27 Nov, 2011 4:53 pm
Posts: 8
Aimeryan wrote:
Some antivirus apps are notorious for refusing to be properly disabled - not sure Avast is one of those or not but its possible. Could try a complete uninstall of Avast and see if that does anything.

Does your harddrive have ample free space? Tried defragging?

Maybe your video card drivers need updating?

Hope you fix it!

Thanks, there is plenty free space... defrag probably is needed, but I highly doubt that will be the issue... And I am quite sure my gfx drivers are the latest...
Isnt there any tool to verify these things? I mean things like whether my gfx drivers are compatible with this game etc...

Oh, one thing I dont have - that is mobo drivers! Maybe that is the issue, I will check it out...

*edit* hm, I tried Driver detective and everything is up to date :( dunno what the hell is the problem *cry*


Top
 Profile  
 
 Post subject: Re: Framerate goes to 1 per second
PostPosted: Thu 01 Dec, 2011 9:31 pm 
Offline
Developer
User avatar

Joined: Fri 25 Feb, 2011 3:39 am
Posts: 1767
Hmm the zombies are more CPU hungry than the other parts of the game, but really your CPU is much more powerful than mine so it has to be something external... It is definitely the CPU binding up or loading not getting the resources it wants at a decent rate.

Hmm that is strange. Your memory footprint is lower than I would expect for SPAZ. There doesn't seem to be much activity in the screen shot either so I don't see a reason for the game to chug out. I have a feeling it is resource loading causing the problem even more now. I will take a look.


Top
 Profile  
 
 Post subject: Re: Framerate goes to 1 per second
PostPosted: Thu 01 Dec, 2011 10:02 pm 
Offline
Developer
User avatar

Joined: Fri 25 Feb, 2011 3:39 am
Posts: 1767
I dug around in the loading a bit and I made some changes increasing the game's memory footprint. This should drastically reduce the hitching when big ships are spawned and destroyed. However, this won't fix your issue I don't think. It may alleviate it somewhat, by lessening incidental CPU burdens, but it seems like you are experiencing a more drawn out permanent low frame rate?

I guess I am asking if the framerate is good half the time and the other half just tanks, or is it consistently bad (i.e. 1 fps) I am certain this bug is somehow software collision related since your computer could easily beat mine in a fight :) However I also want to see if I can make some changes on my end that may resolve the issue. As it stands now, the game will do less loading when big ships arrive, which will give anti virus programs less of a chance to get their grubby paws on the art files which could help.

This change (as long as it doesn't break anything when I test it) will be a part of the next release which should be mid December. Waiting two weeks really sucks, but our current build is in a state that is kind of open heart surgery on the table so I can't dump files as I usually do. I may be able to futz around with an older version of the game though to let you try the changes, so stay tuned on that front. Doing a lot of juggling right now.


Top
 Profile  
 
 Post subject: Re: Framerate goes to 1 per second
PostPosted: Thu 01 Dec, 2011 10:12 pm 
Offline
Shortbus

Joined: Sun 27 Nov, 2011 4:53 pm
Posts: 8
OK mate, thank you very very much for your care! Ill stay tuned :)

*edit* - btw, I realized that I probably have this kind of issue in other games too... But - firstly, Im not sure its not given by their high demands (but still, I can play e.g. Crysis almost smoothly) or by THE problem in my pc.. but how to uncover it? :(
In theory, it might be a CPU problem. But how...


Top
 Profile  
 
 Post subject: Re: Framerate goes to 1 per second
PostPosted: Fri 02 Dec, 2011 2:03 am 
Offline
Developer
User avatar

Joined: Fri 25 Feb, 2011 3:39 am
Posts: 1767
Most modern games are much more taxing to your GPU than CPU, for example Crysis is pushing absolute tonnes of polys, but at any given time, not too much is actually going on in the game so the CPU doesn't have to do too much work. On the other hand in SPAZ, the GPU gets a break, but the CPU gets inundated with all kinds of work due to all the AI activity. I don't think it is a hardware issue for you. I think there is some software being a bit of a menace to the loading system, but I am not sure what. There is a recent post that is similar on the Steam forums, but it is FSecure/Charter related.

Quote:
http://forums.steampowered.com/forums/showthread.php?t=2262296


Top
 Profile  
 
 Post subject: Re: Framerate goes to 1 per second
PostPosted: Thu 29 Dec, 2011 9:24 am 
Offline
Shortbus

Joined: Sun 27 Nov, 2011 4:53 pm
Posts: 8
any update for us who have issues with multicores vs. spaz...?


Top
 Profile  
 
 Post subject: Re: Framerate goes to 1 per second
PostPosted: Thu 29 Dec, 2011 11:50 pm 
Offline
Developer
User avatar

Joined: Fri 25 Feb, 2011 3:39 am
Posts: 1767
No new optimizations unfortunately. There has not been time vs. other demands. There is a noCritters patch floating around on here somewhere that you may be able to find (although it may be out of date) and that could lighten the load a bit. Also turning debris and effects down should provide at least a little relief. Also winamp I noticed does not play well with SPAZ.


Top
 Profile  
 
 Post subject: Re: Framerate goes to 1 per second
PostPosted: Mon 09 Jan, 2012 12:48 am 
Offline
Shortbus

Joined: Mon 09 Jan, 2012 12:41 am
Posts: 8
My $0.02. I'm currently running 1.016 on the latest Parallels on Mac OS X 10.6.

After playing for an indeterminate amount of time, my framerate will suddenly drop to ~1fps.

Some observations...

- this happens whether or not my antivirus is active
- this happens whether or not in Direct X compatible mode
- this happens at multiple resolutions
- this happens in the early levels of the game (as far as I've got) even while idling next to the mothership with nothing going on
- a quit + restart of the entire game reliably cures the problem until it happens again (at random)
- a simple quit-to-main-menu / load never cures the problem

As you can imagine, I'm really trying to stick at this game as I'm loving what I've seen so far. But currently I'm having to quit / reload it 6-10 per hour (on average - sometimes its more like 1) in order to play it.


Last edited by gelfman on Mon 09 Jan, 2012 12:41 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: Framerate goes to 1 per second
PostPosted: Mon 09 Jan, 2012 5:25 am 
Offline
Boomerang
User avatar

Joined: Sun 02 Oct, 2011 12:00 am
Posts: 255
Location: England
Gelfman, it sounds like a memory leak to me resulting in the game running out of memory causing it to chug along at 1fps. Quitting the game would free up the memory thus solving the problem (temporarily) just as you describe.


Top
 Profile  
 
 Post subject: Re: Framerate goes to 1 per second
PostPosted: Wed 11 Jan, 2012 2:23 am 
Offline
Shortbus

Joined: Wed 11 Jan, 2012 2:14 am
Posts: 2
I experience this problem, as well. I Just recently encountered the Zombies, and the game is now unplayable.

Things I've tried:

  1. Running in windowed mode
  2. Running with lower resolution
  3. Turning effects (sliders) down/off.
  4. Turning effects (the checkboxes) off.
  5. DirectX Compatibility Mode
  6. Using different weapons (only cannons, only beams, only missiles, etc)
  7. Updating my graphics card drivers.

Note that I have NOT tried the "nocritters.zip" patch/mod.

None of this has helped. In big battles, I drop to 1 frame per second or less.

Things I've noticed:

  • Big explosions of big ships incur more performance penalty than small ships' explosions.
  • When the ship I am controlling is destroyed, the framerate almost immediately reverts to "normal."
  • This slowdown was absent prior to encountering zombies.

System specs:
  • OS: Windows Server 2008 R0 x64 Enterprise Edition
  • CPU: Pentium D (2-core) 3.0 GHz
  • GPU: NVidia 9800 GT, 1GB DDR2
  • RAM: 5GB DDR2 @ 667 MHz
  • No antivirus software
  • This is a ~7 year old machine.

I'll keep an eye out for an update to the game on steam, but I can't continue playing.

Just lettin' y'all know.


Last edited by Gengar003 on Wed 11 Jan, 2012 7:23 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: Framerate goes to 1 per second
PostPosted: Wed 11 Jan, 2012 6:03 pm 
Offline
Developer
User avatar

Joined: Fri 25 Feb, 2011 3:39 am
Posts: 1767
Hmm, it could be virus scanner related when lots of file loads occur. My machine is about 5 years old (2.4 ghz dual core) and it runs quite well, but I don't run any virus scanners. Could you try turning it off?


Top
 Profile  
 
 Post subject: Re: Framerate goes to 1 per second
PostPosted: Wed 11 Jan, 2012 7:22 pm 
Offline
Shortbus

Joined: Wed 11 Jan, 2012 2:14 am
Posts: 2
There is no virus scanner installed on my system.


Top
 Profile  
 
 Post subject: Re: Framerate goes to 1 per second
PostPosted: Thu 12 Jan, 2012 4:17 pm 
Offline
Shortbus

Joined: Mon 09 Jan, 2012 12:41 am
Posts: 8
Indeed - and note from my posting that having the AV active / inactive makes no apparent difference. Also that, unlikely my fellow poster above, I have found that my frame-rate never recovers. I will try purposely recycling / destroying all of the ships in play when it happens next time as there's a hint above that whatever leak / error may be occurring here is fixed by destroying a ship instance.


Top
 Profile  
 
 Post subject: Re: Framerate goes to 1 per second
PostPosted: Mon 16 Jan, 2012 5:39 pm 
Offline
Developer
User avatar

Joined: Fri 25 Feb, 2011 3:39 am
Posts: 1767
do you guys mind sending your console.log files from when the slowdown occurs. Slowdown is common late game, but should be pretty much non existent early on. Also I am not sure if I mentioned this above, but setting the process affinity for SPAZ to a cpu other than 0 can help. Giving it higher priority as well on the new CPU is good.


Top
 Profile  
 
 Post subject: Re: Framerate goes to 1 per second
PostPosted: Tue 17 Jan, 2012 10:33 pm 
Offline
Shortbus

Joined: Mon 09 Jan, 2012 12:41 am
Posts: 8
Console log attached. Note I tried recycling all my ships when the slowdown occurred but to no avail.


Attachments:
console.log [4.89 KiB]
Downloaded 91 times
Top
 Profile  
 
 Post subject: Re: Framerate goes to 1 per second
PostPosted: Wed 18 Jan, 2012 7:07 pm 
Offline
Developer
User avatar

Joined: Fri 25 Feb, 2011 3:39 am
Posts: 1767
Hmm the console log doesn't contain anything that strikes me as unusual. So you are saying you have a slowdown even with no ships flying around? I am not sure if you have tried this, but it could be an OpenGL issue with your card. Have you tried directX compatibility mode?


Top
 Profile  
 
 Post subject: Re: Framerate goes to 1 per second
PostPosted: Thu 19 Jan, 2012 12:43 am 
Offline
Shortbus

Joined: Mon 09 Jan, 2012 12:41 am
Posts: 8
Per my original post, Direct X compatibility mode makes no difference. Leaving the game in an idling state seems to bring the effect on faster to the extent that I didn't hit space for a while on the pre-start-menu welcome-text screen and, when I finally did, the ship battle behind the start menu was subject to the exact same framerate issue. Note my 'card' is a virtual one as I'm using Parallels.


Top
 Profile  
 
 Post subject: Re: Framerate goes to 1 per second
PostPosted: Thu 19 Jan, 2012 7:37 am 
Offline
Developer
User avatar

Joined: Fri 25 Feb, 2011 3:39 am
Posts: 1767
Hmm I missed that in the original reading, that you were emulating windows. We have a Mac version due out soon, and your key will work for that as well. I am thinking that the best thing to do may be to wait until then. Your save games will also remain intact. The only other thing I see is that your parallels 'card' is reporting openGL2.1 but 3.0 has much better performance.


Top
 Profile  
 
 Post subject: Re: Framerate goes to 1 per second
PostPosted: Fri 20 Jan, 2012 3:30 am 
Offline
Developer
User avatar

Joined: Fri 25 Feb, 2011 3:39 am
Posts: 1767
I just posted something here that may help:

http://www.spacepiratesandzombies.com/forums/viewtopic.php?f=15&t=2648

please let me know if you notice an improvement.


Top
 Profile  
 
 Post subject: Re: Framerate goes to 1 per second
PostPosted: Fri 20 Jan, 2012 8:03 pm 
Offline
Shortbus

Joined: Mon 09 Jan, 2012 12:41 am
Posts: 8
I tried that patch but I'm afraid it didn't help. When the framerate suddenly drops it's like the whole game engine has suddenly changed state. In addition, I popped open Windows' resource monitor and noted no spike in CPU or memory usage when it happened - so it doesn't seem to be some sort of runaway busy loop.


Top
 Profile  
 
 Post subject: Re: Framerate goes to 1 per second
PostPosted: Fri 20 Jan, 2012 10:37 pm 
Offline
Developer
User avatar

Joined: Fri 25 Feb, 2011 3:39 am
Posts: 1767
oh that is really odd if the CPU isn't spiking. The Mac version is getting close to completion. I hope that will resolve the issue for you.


Top
 Profile  
 
 Post subject: Re: Framerate goes to 1 per second
PostPosted: Wed 25 Jan, 2012 4:33 am 
Offline
Shortbus

Joined: Sat 14 Jan, 2012 4:36 pm
Posts: 4
Location: New York, United States
Thanks for the Core affinity trick Blorfy! I had the problem with large battles with huge ships slowing down the game. Changing the affinity to a core other than zero helped a lot. Mind you, the slowdown didn't entirely go away, but it's so infrequent and so brief, it's not even an issue. It's actually more like lag than slowdown.

Oh, and great job on this game. I bought a lot of great games on the Steam sale last month, and I always come back to this game the most.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 54 posts ]  Go to page Previous  1, 2, 3  Next

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group